Game in Mind

Cities: Skylines – 80’s Downtown Beat Steam

Cities: Skylines – 80’s Downtown Beat Steam

Categories: ,

$4.66

Description

NOTICE: Activation key must be used on a valid Steam account. Requires an internet connection.

Feeling the asphalt melting under your feet? Got stuck in a traffic jam? What about stepping on a cramped train? Breathe in the modern City! Put your headphones on and lace up your rollerskates with the 80’s Downtown Beat radio.

The Radio Station includes 16 songs for more than one hour of music!

Steam account is required for game activation and installation.
This content requires the base game Cities: Skylines on Steam in order to play.

Windows Requirements

Minimum:

  • Requires a 64-bit processor and operating system
  • OS: Windows® 7 64 Bit | Windows® 8.1 64 Bit | Windows® 10 Home 64 Bit
  • Processor: Intel® Core™ I7 930 | AMD® FX 6350
  • Memory: 8 GB RAM
  • Graphics: Nvidia® GeForce™ GTS 450 (1 GB) | AMD® R7 250 (2 GB) | Intel Iris Xe G7 (Tiger Lake)
  • DirectX: Version 9.0c
  • Network: Broadband Internet connection
  • Storage: 4 GB available space

Recommended:

  • Requires a 64-bit processor and operating system
  • OS: Windows® 10 Home 64 bit
  • Processor: Intel® Core™ I7 2700K | AMD® Ryzen 7 2700X
  • Memory: 16 MB RAM
  • Graphics: Intel® Core™ I7 2700K | AMD® Ryzen 7 2700X
  • DirectX: Version 11
  • Network: Broadband Internet connection
  • Storage: 4 MB available space

Mac OS Requirements

Minimum:

  • Requires a 64-bit processor and operating system
  • OS: OS X 10.11 (64-bit)
  • Processor: Intel Core 2 Duo, 3.0GHz
  • Memory: 4 GB RAM
  • Graphics: nVIDIA GeForce GTX 260, 512 MB or ATI Radeon HD 5670, 512 MB (Does not support Intel Integrated Graphics Cards)
  • Network: Broadband Internet connection
  • Storage: 4 GB available space

Recommended:

  • Requires a 64-bit processor and operating system
  • OS: OS X 10.11 (64-bit)
  • Processor: Intel Core i5-3470, 3.20GHz
  • Memory: 6 GB RAM
  • Graphics: nVIDIA GeForce GTX 660, 2 GB or AMD Radeon HD 7870, 2 GB (Does not support Intel Integrated Graphics Cards)
  • Network: Broadband Internet connection
  • Storage: 4 GB available space

Linux Requirements

Minimum:

  • Requires a 64-bit processor and operating system
  • OS: Ubuntu 12.04 (64-bit)
  • Processor: Intel Core 2 Duo, 3.0GHz or AMD Athlon 64 X2 6400+, 3.2GHz
  • Memory: 4 GB RAM
  • Graphics: nVIDIA GeForce GTX 260, 512 MB or ATI Radeon HD 5670, 512 MB (Does not support Intel Integrated Graphics Cards)
  • Network: Broadband Internet connection
  • Storage: 4 GB available space

Recommended:

  • Requires a 64-bit processor and operating system
  • OS: Ubuntu 14.10 (64-bit)
  • Processor: Intel Core i5-3470, 3.20GHz or AMD FX-6300, 3.5Ghz
  • Memory: 6 GB RAM
  • Graphics: nVIDIA GeForce GTX 660, 2 GB or AMD Radeon HD 7870, 2 GB (Does not support Intel Integrated Graphics Cards)
  • Network: Broadband Internet connection
  • Storage: 4 GB available space
0

Your Product Basket

The Cart is Empty
No Product in the Cart!
$0.00
$0.00
$0.00